Cisco Programlama Komutları

Cisco Programlama Komutları

Genel Komutlar
Hostname name : Cihaza hostname vermek için kullanılır.
clear ip route * : Enable modunda yazılır ve routing table bilgisini temizler.
Enable secret PASSWORD : Configurasyon moduna girişte parola sordurmak için kullanılır.
line console 0 : Console’un 0. Portunu seçmek anlamına gelir.
password PASSWORD : Console’a parola vermek için kullanılır.
login : Console’a bağlanılırken parola sorulmasını sağlamak için kullanılır.

Bu 3 komut bir team halinde kullanılır.
line vty 0 4 : Telnet ile kaç kişinin bağlanacağını belirtmek için kullanılır.
password PASSWORD : Telnete parola vermek için kullanılır.
login : Telnet’e bağlanılırken parola sorulmasını sağlamak için kullanılır.
banner motd # message # : Cihaz açılırken açıklama amaçlı mesaj belirtilmesi için kullanılır.
service password-encryption: Bu komut cihaz üzerinde belirlenmiş olan tüm şifreleri encrypt eder.
copy running-config startup-config: Router üzerinde yapılan değişiklikleri kalıcı bir yere kayıt etmek gerekir.Bu kalıcı alan NVRAM olarak adlandırılır.
Interface configure etmek ile ilgili komutlar

interface type number : Interface seçmek için kullanılır.
Örn: interface FastEthernet 0/0
ip address address mask : Interface’e IP ve Mask atamak için kullanılır.
Örn: ip address 198.168.1.1 255.255.255.0
description description : Tanımlama amaçlı kullanılır.
Örn: description MESAJ
clock rate : İki router serial portlardan bağlandıysa, routerların birisinde bu komut yazılmalı ve clock rate belirtilmelidir.Clock rate komutu bu amaçla kullanılır.
Örn: clock rate 64000
no shutdown : Kapalı olan interface’i devreye almak için kullanılır.
Örn: no shutdown
NOT: Bu 5 komut bir set halinde kullanılır.Description komutu mecburi değildir.

Routerda VLAN Yapılandırmak

null0 : Gerçekte varolmayan ve fiziksel olarak erişeleyemecek bir interface’dir.
redistrubute static : Rip’de yazılırsa, o routerdaki static routelarıda komşu routerlara gönder demektir.

Show Komutları

show running-config : Çalışan configurasyon bilgisini gösterir.
show ip route : Cihazdaki routing table bilgisini gösterir.
show ip interface brief : Cihaz üzerindeki interface’lere atanmış IP’leri ve UP/DOWN olup olmadıklarını gösterir.
show interfaces : Cihazdaki tüm interfacelere ait detaylı bilgi verir.
show interface Serial 0/0/0 : Sadece ilgili interface ile ilgili bilgileri gösterir.
show controllers Serial 0/0/0 : Sadece ilgili interface ile ilgili bilgileri gösterir.
show ip route database : Komutun yazıldığı makinedeki RIP ile gelen routing table bilgisini gösterir.
show ip route 192.168.2.0(HEDEF IP) : Hedef network ID’sine nasıl gidileceğinin detaylı bilgisini verir.

debug ip rip : rip ile ilgili olayları görüntülemek için kullanılır.
undebug ip rip : ilgili konuyla ilgili olayları görüntülemeyi durdurmak için kullanılır.
undebug all : tüm olay görüntülemesini durdurur.

default-information originate : Bu komut Boundary Router üzerinde “router rip” yapılandırmasında kullanılır.

Static Route Komutları

ip route : Static Route girmek için kullanılır.
ip route 192.168.1.0(HEDEF IP) 255.255.255.0 192.168.3.1 (Paketin gönderileceği interface)
no ip route : no ip route 172.16.1.0(HEDEF NETWORK) 255.255.255.0 192.168.1.2(PAKETİN GÖNDERİLECEĞİ INTERFACE)

Hardware Routerlarda Rip

Rip açıldığında Router hangi networklere direk bağlı ise o networkler tanıtılır.Bu işlem karşılıklı iki Routerda da yapıldığında routing table transferi otomatik olur.
router rip : Rip configure menüsüne girmek için kullanılır.
network NETWORK ID’SI : Rip ile transfer edilecek network ID’sini transfer etmek için kullanılır.

R1 (config)# ip route 192.168.1.0 255.255.255.0 null0
R1 (config)# router rip
R1 (config-router )# redistribute static
R1 (config-router )# network 10.0.0.0
R1 (config-router )# network 192.168.1.0

R1 (config-router )# no auto-summary

Ripv2 : Classless IP’leri transfer etmek için Ripv2 kullanılabilir.Ripv2 configure etmek için gereken komutlar aşağıdaki gibidir.
R1 (config)# router rip
R1 (config)# version 2

Öneri : Ripv2’de auto summary’i kapatmak önerilir.

Metric: Router üzerine gelen paketi hedefine ulaştırmak için birden fazla yola sahipse bu yollardan birisini tercih etmelidir.Metric değeri küçük olan route bilgisi önce tercih edilir.

Metric değerini belirleyen kıstaslar

1-) Hop Count: Hedefe kaç router atlayarak gidileceğini belirtir.Birinci yolda atlanacak tek router varsa ve diğer yolda birden fazla router varsa birinci yolun metrici daha küçük olabilir.
2-) Bandwith: Hedefe ulaşırken geçilecek yolun band genişlliği önem kazanır.Daha büyük band genişliğine sahip olan yol önce tercih edilmelidir.Bu yolun metrici küçük olabilir.
3-) Hat yoğunluğu: Bir hat çok hızlı olmasına rağmen üzerinde aşırı trafik olabilir.Böyle bi durumda da bu hat tercih edilmemelidir.

Equal Coast Load Balancing(Eş Değer Yük Dağılımı)

CDP(Cisco Discovery Protocol)

Cisco Routerlara veya Switchlere komşu olan Cisco deviceları görebilmeye ve onlar hakkında bilgi almaya yarar.

show cdp neighbors :
show cdp neighbors detail :

Dynamic Routing Protocolleri

Classful: A, B, C sınıfından network ID’lerine verilen genel isimlendirmedir.Başka bir deyişle /8 /16 /24 maskını kullanan network ID’lerine denir.
Classless: Hangi classta olduğu belli olmayan network ID’lerini tarif eden isimlendirmedir.Örneğin /25 maskında olan bir network ID’sidir.

Classful Routing Protocolleri
RIPv1:
IGRP:
EGP:

Classless Routing Protocolleri
RIPv2:
EIGRP:
OSPFv2:
IS-IS:
BGPv4:

Ipv6 Routing Protocolleri
RIPng:
EIGRP for IPv6:
OSPFv3:
IS-IS for IPv6:
BGPv4 for IPv6:

Çalışma Prensiplerine Göre Routing Table Transfer Protocolleri
1. Sınıf
Distance Vector Routing Protocoller: RIPv1 – RIPv2 – IGRP – EIGRP
Bu protocoller routing tableları transfer ederken hop sayısındaki değişikliğe göre transferi tetiklerler.

2. Sınıf
Link State Routing Protocoller: OSPFv2 – IS-IS
Bu protocoller routerın networklere olan fiziksel bağlantısındaki durumun değişikliğine göre transferi tetiklerler.Örneğin, routerın networke bağlı olan interface’i up ise bu networke erişebildiğini diğer routerlara söyler.Eğer aynı interface down duruma düşerse, artık bu networke erişilemeyeceğinide diğer routerlara söyler.

Convergence
Yapıdaki tüm routerların birbirlerinin routing tablelarını update etmeleri için geçen sürenin toplamıdır.

Slower Convergence: RIP ve IGRP
Faster Convergence: EIGRP ve OSPF

Administrative Distance
Aynı hedefe gitmek için birden fazla routing table satırı varsa Administrative Distance’ı küçük olan tarif öncelikli kullanılır.

Count to Infinity
Routing Table transferi Loop’a girerse hop bilgisi maximum 16’ya ulaştığında o routing satırı için transfer işlemi durur.

Holddown Timer
Router, komşu Router’ından bir networkün down olduğuna dair bilgi aldığında diğer routerlardan gelicek olan down duruma düşmüş network için update taleplerini “Holddown Timer” süresi boyunca kabul etmez.Bu kabul etmeme durumu Loop’u engeller.Bu süre içerisinde down olan network up duruma gelmediyse bekleme süresi dolan routerlardan sırayla down olan networke ait routing table bilgisi silinir.

Split Horizon Kuralı
Routerın routing table bilgisini update ettiği interface’den aynı bilgiyi bir daha göndermemesi demektir.

Route Poison
Router down olmuş networküne ait kaydın hop değerini 16 olarak işaretler(ki bu durum o networkün down olduğu anlamına gelir) ve bu route bilgisi bu haliyle diğer routlerlara gönderilir.

TTL in Effect
Bir paket Loop’a girse bile gezebileceği router sayısı sabittir.Bu değere TTL(Time to live) denir.Ve her bir router geçişinde bu değer 1 eksilir.Değer 0 a geldiğinde gezebileceği router kalmamıştır, paket ölür.

Passive Interfaces
Router pasif duruma getirilen interface’den routing table bilgisi almaz.
Bu durum router rip bölümüne girildikten sonra “passive-interface FastEthernet 0/0” komutu ile aktif hale getirilir.

Loopback Interface
Gerçekte olmayan sanal bir interface’dir.

NOT: no ip classless ve ip classless komutlarının anlamı
no ip classless : Router, route ederken sadece classful network uygunluğuna bakarak karar verebilir.
ip classless : Router, yönlendirme yaparken classful route arama zorunluluğu ortadan kalkar.En uygun bit sayısına göre denk gelen route’a yönlendirilme yapılır.

Varsayılan kabuller
Cisco 11.3’den daha eski versiyona sahip IOS’larda varsayılan olarak no ip classless ayarını kullanmaktadır.(11.3 dahil değil)
Cisco 11.3 dahil ve daha yeni versiyona sahip ise IOS’larda varsayılan olarak ip classless ayarını kullanmaktadır. (11.3 dahil)
Routerda bu bilgiyi görmek için show running-config komutu kullanılır.

Enhance IGRP
Varsayılan olarak auto-summary yapar.

R1 (config)#router eigrp 1 : EIGRP devreye almak için kullanılan komuttur.Buradaki “1” birbirleriyle iletişimde olacak routerları tarif eder.
R1 (router-config)# network 192.168.1.0(NETWORK ID’si) 0.0.0.255(Mask)
R1 (router-config)# no auto-summary

wildcard mask : Mask yazılırken serbest kalan bit sayısını tarif ederek mask yazılmasına denir.
Örn: 255.255.255.252 => 0.0.0.3 / 255.255.255.0 => 0.0.0.255

EIGRP’nin routing table’daki notasyonu “D” dir.

EIGRP’deki metric hesabında kullanılan K değerlerinin atanması
R1(config-router)# metric weights tos k1(1/0) k2(1/0) k3(1/0) k4(1/0) k5(1/0)

K1 (bandwith)= 1
K2 (load)= 0       (Hat üzerindeki yük)
K3 (delay)= 1     (Gecikme)
K4 (reability)= 0 (Hattın güvenilirliği)
K5 (reability)= 0 (Hattın güvenilirliği)

Serial Interface’lere bandwith değeri söylemek
R1(config)# interface serial 0/0/0
R1(config-if)# bandwith 64
R1(config)# interface serial 0/0/1
R1(config-if)# bandwith 1025

OSPF (Open Shortest Path First)
Administrative Distance : 110

OSPF yapılandırma komutları
R1(config)# router ospf 1(process ID)
R1(config-router)# network 192.168.1.0 0.0.0.255 area 0

Router ID: Router’ın üzerinde atanmış olan IP’lerden en büyük olan IP olarak belirlenir.Router ID görüntülemek için “show ip protocols” komutu kullanır.
NOT: Bazı IOS’larda show ip protocols komutu ile Router ID görüntülenemeyebilir.O zaman “show  ip ospf veya show ip ospf interface” komutları kullanılır.

show ip ospf neighbor: Bu komut, ospf ile öğrenilmiş komşu routerları göstermek için kullanılır.Ayrıca bu komut DR ve BDR olan routerları söyler.

Interface’in bağlı olduğu hattın cost değerini görmek için
show ip ospf interface serial 0/0/0

Static Cost Atamak
Cost atanacak hattın bağlı olduğu interface seçilir ve aşağıdaki komutlar uygulanır.
interface serial 0/0/0
ip ospf cost 1562

DR (Designated Router): Bir ospf networkünde tüm routerların routing table bilgisini almakla sorumlu olan routera verilen isimdir.Router ID’si büyük olan router DR olur.
BDR ( Backup Designated Router): DR olan routerda herhangi bir sorun çıktığında sorumluluğu üzerine alacak yedek Designated Router’dır.
DROTHER: DR veya BDR’da bir sorun olduğunda, onlardan herhangi birisinin yerini alacak olan Routerdır.

OSPF Interface’e Priority Atamak
interface fastethernet 0/0
ip ospf priority 200(0-255 aralığında herhangi bir rakam olabilir.Priority numarası küçük olan önce tercih edilir.)
Cisco Devicelar Hierarşik olarak 3 bölüme bölünmüştür.
Access: Clientlar ve giriş seviyesi cihazlar bulunur.Çok üst seviyede cihazlar değildirler.PC’ler, Printerlar
Distribution:Access layerındaki cihazları birbirine bağlamak için kullanılan switchleri barındırır.Orta ve üst seviye cihazlardır.
Core:İletişimin en uç noktasındaki cihazlardır.Back-bone hatlarda çalışan deviceların bulunduğu layerdır.

Half Duplex ve Full Duplex
İki makine arasındaki iletişimin aynı anda tek yönlü olmasına Half Duplex denir.
İki makine arasındaki iletişimin aynı anda iki yönlü olmasına Full Duplex denir.

Collection Domain
Çakışma ihtimali oluşturabilecek makinelerin bulunduğu alana verilen isimdir.Hub ile birbirine bağlı olan makineler collection domaini oluştururlar.Collection domaini switchte biter.

Broadcast Domain
Bir broadcast paketinin gidebileceği makinelerin oluşturduğu alanın ismidir.Broadcast domainleri routerlara kadardır.

Network Latency
Paketin kaynaktan hedefe gidene kadar geçen süredir.

Duplex Mode Komutları

S1(config)#interface fastethernet 0/1
S1(config-if)#duplex auto
S1(config-if)#speed auto

Çalışan ayarları yedeklemek
copy startup-config flash:config.back1(dosyanın adı)
copy flash:config.back1 startup-config
copy running-config tftp://172.16.2.155/tokyo-config
erase nvram: NVRAM’deki tüm veriyi siler.
TFTP Server: TFTP bir dosya transfer protocolüdür.Bu protocolü kullanan makineye TFTP Server denir.

Switch’de Trunk Portu
Switch üzerine gelen paketi gönderene göre farklı bir network ID’sine atması gerekiyorsa(Örn, Switch’e paketi gönderen makine 10.0 network’ünde ve paketin itmesi gereken makine 30.0 network’ünde) bu durumda switch paketi routera atmak zorundadır.Trunk portu switch’in paketleri routera göndereceği porttur.

S1(config)# interface fastethernet 0/5
S1(config-if)# switchport mode trunk

Switch’lerde Access Mode
Switch’e erişmek üzere clientların switch’in hangi portuna bağlı olduğunu tarif eder.

Resimdeki, Fast0/11 ve Fast0/6 access modunda çalışması gereken portlardır.
S1(config)# interface fastethernet 0/11
S1(config-if)# switchport mode access

Switch’lerin Access Portlarını ilgili VLAN ile ilişkilendirmek

S1(config)# vlan 10
S1(config-vlan)# vlan 30
S1(config-vlan)# exit
S1(config)# interface fastethernet 0/11
S1(config-if)# switchport mode access
S1(config-if)# switchport access vlan 10
S1(config-if)# interface fastethernet 0/6
S1(config-if)#switchport mode access
S1(config-if)#switchport access vlan 30

show vlan brief :

ÖNEMLİ NOT: Switch’lerde hiç configurasyon yapılmasa bile VLAN1 isimli bir default VLAN vardır ve switch’in tüm portları bu VLAN’dadır.

Cevapla

E-posta adresiniz yayınlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir. *

*