Etiket Arşivi: excel 2010 formülleri

Excel Eğer Formülü

Açıklama Mantıksal kontrol’ün sonucu DOĞRU ise bir değeri, YANLIŞ ise başka bir değeri verir. Değerler ve formüller üzerinde koşula bağlı testler yapmak ve testin sonucu temelinde bir işleme yönelmek için EĞER işlevini kullanın. Testin sonucu EĞER işlevinin verdiği değeri belirler.

Kullanılış Şekli

=Eğer(Şart ; doğruysa_değer ; yanlışsa_değer)

Evet, biliyorum yukarıdaki gibi ağır kitabi ifadeler canınızı sıkıyor. Fakat biz ifadeleri gerektiğince bol örnek verip anlaşılmasını kolaylaştıracağız.

Eğer kelimesini siz günlük yaşantınızda da sık sık kullanıyorsunuz. Mesela arkadaşınıza kullandığınız şu ifadedeki gibi. “Eğer Hasan gelirse, ben de gelirim” Diğer bir ifadeyle: “Benim gelmem için Hasan’ın da gelmesi şart”.

Verdiğimiz misali iyi inceleyelim. Arkadaşınız sizi bir yere davet ediyor. Siz de arkadaşınıza bir şart koşuyorsunuz. Şartınız Hasan’ın da aynı davete gelmesi. “Eğer Hasan gelirse” diyorsunuz.

Demek ki,
Hasan gelirse siz de gideceksiniz,
Hasan gelmezse siz de gitmeyeceksiniz.

Şimdi canınızı sıkan şu formüle göz atın ne kadar anlaşılır olduğunu göreceksiniz.

=Eğer(Şart ; doğruysa_değer ; yanlışsa_değer)

Eğer:
Sizin cümlenizin başında kullandığınız Eğer’in aynısını ifade eder.
Şart:
Yapılmasını istediğiniz şey. Yani Hasan’ın davete katılması.
Doğruysa_değer:
İsteğiniz yapılırsa, şartınız kabul edilirse yazdırılacak durum. Yani Hasan davete gelecekse, “tamam geliyorum” yazdırılır.
Yanlışsa_değer:
İsteğiniz yapılmazsa, şartınız kabul edilmezse ekrana yazdırılacak durum. Yani Hasan gelmeyecekse, “hayır gelmiyorum” yazdırılır.

Yukarıda verdiğimiz örneği Excel Hesap Tablosu üzeride gösterelim.

1. B2 Hücresine şu formülü girin. =EĞER(A1=”gelsin”;”Tamam geliyorum”;”Hayır gelmiyorum”)

Devamını Oku »